WinDisp User Group Meeting 2015
Gravity Data for Quest West, British Columbia, Canada
1. Start a new layout in WinDisp , double-click on the Post Data from a Geosoft Database,  select the Gravity - GDB Point Data - GDB Données ponctuelles.gdb
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2. Click on the Next button and check that the file has been decoded correctly:
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3. Click on Done, and the data file format definition stage is now complete and you now need to define how the data is to be displayed on the map. The first step is to select the posting style:
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4. Select the Value posting style as this is the one that is most useful for displaying and gridding point data. Then click on OK and you will be prompted to define the X and Y coordinates for posting the points on the map:
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5. Select the Longitude and Latitude data fields as the X and Y respectively and select the Decimal Degrees coordinate style. Next click on the Define Projection and Datum Transform button to display the projection definition form

[image: image5.png]£ Define Source Datum Definitions

Coordinate System for Source Data

o]

Coondinate System | =] _befine Projecion
Projection  [Local Grid =] Zone Number [ 0fa]
Soheroid [Austalon National Spheroid

Henisphere [Southern Hemisphere ERM Name |

Falso Easting False Northing Scale Factor
] 00000 | To000000 | 0.95%5
Longitude Origin_~ Latituds Origin Zone Width

[ oo00mE |  00000N | 600000

Standard Parallel 1 Standard Parallel 2

000.000N 000.000N

Reset

Optional Datum shift between source datum and map display datum

Transform [Hone

Description

ox  [o0000 ov [o0000 oz

Ty

Rx [00000 Ry [o0000 rz

sc [oo000 Apply Inverse Datum Shitt [V
Create New Datum

TostTransiorm cancer |

o000





6. Click on the Define Projection button, fill in the definitions as shown below, click on the Save New and save the projection as UTM10N
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7. Click on Done and then on the Test Transform button and enter the Longitude value as -121.90894 and Latitude as 52.29421. Then click on the Lat/Lon -> East/North button and check that the East is 574408.7 and North is 5794322.4.
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8. Click on Done to return to the main projection definitions form, select the projection UTM10N
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9. Close the projection form by clicking on Done and then click on OK to display the Data Posting Specification form. Then click on the first line under the Name of Data Variable column and select the Bouguer as the data value to post:
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10. Click on the Display Data Range button and the statistics of the data values read from will be displayed:
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11. Click on the Copy Limits > To Plot Limits menu item and set the map scale to 500000, then click on Done, OK and the on the Display! Menu item to check that the data is being decoded and displayed correctly.
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12. Click on the File> Save Layout As menu item and save the layout definitions to the file Gravity - GDB Point Data posting.csf
13. Click on the Ruler icon in the toolbar and measure the distances between data points to give you a sense of the data spacing over the area (distances vary greatly from about 2km to 20km)
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14. Click on the Edit> Posting> Edit posting Specifications menu item to return to the Posting definition form and select the ELEVATION, FREEAIR and TCOR data fields:
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15. click on the Define Data Variable button and the Variable Posting specification form is displayed:
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16. The labels are all being posted to the right of the position marker, so are not legible. You can experiment with label positioning by selecting each data column using the drop-down list at the bottom left of the form and changing the Position (and other parameters at the top of the form). Click on the Redraw button to see the effect of the changes. (Note that the first data record in the database has a valid location, but this is followed by a lot of records with no valid location, so these will not be displayed on the form). Alternatively you can simply set the Label Size to 0 and then click right on the Label size caption and select Copy to All from the popup menu and the a Redraw will show only the position marker.

17. Click on the Display Data Range button and select Bouguer as the data variable and fill in the grid cells size, search radius values, Output file name and format as follows:
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18. The data can now be gridded by simply clicking on the Grid Data button, but as we have a number of data fields of interest, click on the Show Grid Options button and turn on the Grid All Data Fields checkbox
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19. The list in the centre of the form shows the data columns to be gridded and the file name for the resulting grid. These can be excluded using the checkbox or the name can be modified as required using the textbox at the right. If the settings are acceptable, click on the Grid Data button and the grid files will be created. (The statusbar at the bottom of the main WinDisp form shows the progress of the gridding and will display a Ready message when the process is complete).

20. Once the grids have been created, return to the main WinDisp form, click on the Edit> Images menu item and select the BC_Endako_BOUGUER.grd grid file. Then select Colour Sun Illumination as the image style when the Image File Specifications form is displayed:
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21. Return to the main form and click on Display!
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22. Clearly the mixed sparsity of the data is causing problems with the gridding, so return to the grid generation form and change the cell sizes to 1000, the output points per cell to 2, the gridding method to Biquad spline and the smoothing parameter to 20:
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23. Regenerate the grids using BC_Endako_BQ.grd as the base name and redisplay the Bouguer grid:
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24. To make it easier to compare the two grids, start a new WinDisp session, start a new layout and click on the Edit> Multi Panel Display menu item
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25. Open a Windows File Explorer and drag the Bouguer grids onto the panel display list and change the column number of the BG grid to display in column 2.
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26. Click on the Define Panel Contents button, select the Image and Topo tab, change the Image style to Colour Sun Illumination. Then click right on the Image Style label and use the Copy to All menu item to set the same style for all image panels.
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27. Go back to the main WinDisp form and display the layout and it is readily apparent that the BG grid is somewhat more realistic than the original minimum curvature version

[image: image24.png]



28. Go back to the Multipanel definition form and Image Options> Export images to MapInfo> All Images menu item, specify an identifying name to prepend to the exported bmp files and click on Done to bring up the MapInfo projections definition form and select an appropriate coordinate system:
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29. Click on Continue and all images will be exported to registered raster images that can be used for display in other programs
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30. The export to raster format can also be performed by opening the Image definitions form and using the Export> BMP/JPG/ArcView/MapInfo menu item, set the output file name and location and the Image Export form will be displayed:
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31. Click on the Store Grid button and the Projection definition form is displayed as before to allow you to define the projection and the raster file will then be created as before.

Inverting the gravity data
1. Click on the Utilities menu and select the Create a mag/grav inversion option
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2. The inversion setup form will then be displayed. Set the Data Type to Gravity:
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3. Click on the Observed Data tab, set Grid Data as the file Type and select the Bouguer grid that was generated in the previous section. Then click on the Set Limits from Data.
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4. Note that the gravity inversion assumes that the units of the data being inverted is mGal and the density units are g/cc. As the Geoscience Australia data is in gravity units, set the Scale value to 0.1 so that the observed data will be converted to mGal for the inversion.

5. Click on the Topo Data tab and select the N53-55W127-124_UTM10N_AOI.grd SRTM grid file:
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6. Click on the Mesh tab and set the X/Y cell sized to 1000, the Z cell size to 500 and the minimum Z to -10000. 
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7. Because of the way that the inversion process works, it is a good idea to try to keep the number of cells in each of the x,y and z directions to just below a power of 2 rather than just above. In this case, the number of Y cells is 143 = 135 + 8 (the 8 being the number of mesh padding cells). To check if it is possible to reduce the number of Y cells to below 128, set the Region to View to Total Region and select the Bouguer image as the Image to view and click on the View Mesh Layout tab
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8. The up/down buttons below the image can be used to shift the left/right and top/bottom limits of the core portion of the inversion and the updated number of cells is displayed in the status bar to the left of the buttons. By shifting the minimum Y and the maximum Y appropriately, it is possible select an area of interest and reduce the number of Y cells to below 128. However, in this particular instance, the area limits have been chosen to match those of other surveys, so we’ll stick with these. 
9. Click on Done and then click on the Create Inversion tab, specify the name of a folder to use for the inversion and any useful comments regarding the choice of parameters and click on the Create Inversion to generate the files
[image: image34.png][3 3D inversion setup: BC_AOL BOUGUER MGinv3D.inp
File Change Working Directory

=10l x]

Paametes | Obosvedsia |

Topo Data

Mesh

Create Inversion

Inversion Location [ a: [DataPart1]

Refresh Dir Qo

Copybirtiame_| | Zygc

Set Work Dir

Savingthe inversion defnitons

Creating inverson parameter fes

Creating inversion batch fie

(Gridding topo deta

Creating inversion mesh fies

(Witing inversion model e

Fieading inversion data fle

Number of deta read from fle: 22680
Ensuing reading elevalions sre consisert ith topo
[Witing observed data fo use i the inversion
IWiting topo data for use in the inversion
Inversion processing complete:

s





10. Navigate to the folder containing the inversion data and you’ll see that there are multiple files that have been created:
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The files fall into three main categories:
Inversion data files:

Mesh: This file contains the definitions of the model volume:
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The file format is fairly simple:

Line 1: number of x, y and z cells

Line 2: X, Y, Z coordinate of the west, south, top corver of the volume

Lines 3…: The X cell sizes, followed by the Y cell sizes and then the Z cell sizes

Lines 6: non-UBC extension defining the topo and how the mesh is draped

Grav.obs: this file contains the data to be inverted
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The first line specifies the number of observation points and following lines contain the X, Y, Z, grav, target_misfit values

Model.den: This is a dummy model file containing all zero density cell values. The file is not used for the inversion, but can be used as a template for building reference and weighting files. The cell values are stored by Z top to bottom first, then X from left to right and then Y from front to back.
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Topo.dat: this file contains the terrain defined as point locations
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30700010000 59130000000 94316567 94316567
30800010000 59130000000 94316567 94316567
30900010000 59130000000 94316567 94316567
31000010000 59130000000 94316567 94316567




The first line specifies the number of terrain location points and following lines contain the X, Y, Z, dtm_mesh, dtm_real

NB for UBC meshes, the dtm is discretised to the mesh, so the dtm_mesh values will be different to the actual elevation. For MGinv3D, the mesh is draped to the topo, so the mesh elevation is the same as the real dtm value

Inversion parameter files:

Mgsen3d.inp: This file contains the parameters for running the MGsen3D program. This program uses only the mesh, grav.obs location information and the topography data  (NB the observed data value is not used from the grav.obs file, just the x,y,z coordinates). The three data files specify the geometry for the inversion model and from this the MGsen3D program generates a compressed forward model mtx file that is used by the MGinv3D program to construct a model which fits the observed data.
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Maginv3d.inp: This file contains the parameters for running the MGinv3D program. This program used the data and misfit values from the grav.obs file (and not the locations) along with the mginv3d.mtx forward calculation file to generate a density model which fits the observed data as well as possible within the constraints imposed by the user (smoothness, nearness to reference model and staying within any specified bounds).
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Bouguer_inversion.inp: While not strictly a parameter file used in the inversion, this file contains a record of all of the settings on the inversion creation form. This file can be loaded onto the form using the File> Read parameters menu item so that the settings can be reviewed and modified as required.
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Inversion batch control files:

run_mgsen3d.bat: This batch file just provides a simple way of starting the MGsen3D program
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run_mginv3d.bat: This batch file provides a simple way to run the MGinv3D program once an mtx file has been generated. Once the inversion completes, the output files are read and an error file and WinDisp display are generated to provide a simple way to determine how well the inversion has performed. Note that once an mtx file has been generated, you can change any of the settings referred to in the mginv3d.inp file (except the reading locations) and you will not need to regenerate the mtx.
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run_inversion.bat: This batch file simply combines the MGsen3D and MGinv3D stages into one 
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run_mgsen3d_cluster.bat: This batch file uses the cluster controller program to generate the mtx file. This requires a little bit of setting up, but can speed up the calculation process quite significantly
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run_cluster_inversion.bat: This batch file combines the call to the cluster version of the mtx calculation with a call to the run_mginv3d batch file to run the inversion
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run_magerror.bat: This batch file takes the observed  and modeled data values and generates a data file with the inversion errors. It also can generate grid files and an inversion error layout if the mesh file is specified on the command line
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Inverting the gravity data

1. Click on the Utilities menu and select the Create a mag/grav inversion option

2. Now that the inversion data files have been generated, we can run it. This can be done either by the standard or cluster versions. This still takes a while as the problem is quite a large one. If we run it using the standard MGsen3D program, the log file shows that it took 102 minutes on a 4.0GHz 16-core computer. However if the cluster version us used, the program interface shows that the calculation will only take 30 minutes.
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3. Once the mtx file has been generated, the inversion can be run and the aux file shows a concise log of the iterations performed:
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4. The log clearly shows that the observed data has been fitted almost exactly and the model norm is reasonably small. Start WinDisp and load and display the Inversion_model_errors.csf layout:
[image: image51.png]



This display shows the observed data in the top left panel and the modeled data in the bottom left panel. The top right panel displays the difference between the observed and modeled data and the bottom right panel shows the percentage difference between them. The is also a panel displaying the Z-score difference ( = (modeled – observed)/target_misfit), but this is turned off by default. The difference grid is coloured using the observed data range (with the average value removed) and the percentage error image is coloured uniformly from -5 to +5. The Z-score grid is coloured uniformly from -2 to +2. The uniform green display shows that the data misfit is very close to zero.
5. To view the model, click on the 3D Models menu item to start the 3D Modeller form and load the mesh and inversion model file:
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6. Click on the View Model tab and select the Topo Draped Depth Slice as the section to view and set the Blue value to 0
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7. Set the Isosurface value to 0.05 and click on the Start 3D Viewer button to see the distribution of higher density values in 3D
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8. To see how the density compares with the Bouguer data, return to the 3DModeller form, click on the 3D Files tab and select the SRTM grid as the topo and the BMP of the sun illuminated Bouguer as the draped image:
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9.  Then click on the Create New 3D Object menu item and name it as DTM + Bouguer. Then select the new item in the list, change the transparency to 0.2 and use the vertical scroll bar to shift the image down until the isosurfaces are more readily visible.
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Calculating terrain corrected gravity data

1. Start the ggCalc program and load the settings from the BC_gravity_data_TC_opt.inp file
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2. Click on the Data locations tab and load the data file:
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3. Return to the Calculations tab and click on the Calculate Terrain Response button and the terrain response will be calculated and output to the specified data file. Note that the program also fills in the average topo and optimal density:
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4. Open a new WinDisp and select the existing BC_TC_gravity_data layout file and click on the Edit> Posting> Edit Posting Specifications menu item to display the Posting definitions form:
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5. Click on the Display data Range button and set up the gridding parameters as before and generate the required grid files.
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6. Once the grids have been generated, open and display the BC_bouguer_TC_comparison layout to display the DTM, supplied Bouguer, terrain corrected data for 2.67 and 2.1 g/cc 
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7. As the TC grids are exactly the same size as the Bouguer grid used for generating the gravity inversion, we can use these grids to create new inversions and use the previously generated mtx file. When this is done, the inversion errors look like this:
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8. If we load the new inversion model and add the same 0.05 g/cc isosurface to the previous 3D model it can be seen that the models agree pretty well overall, but there are some significant differences (TC isosurface is purple)
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9. To put the model into some sort of geological context, we can load a raster of the geology draped on a sun-illuminated dtm. To do this, click on the 3D Files tab and select the Topography and draped image files as follows:
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10. When the image is added to the 3D model, change the transparency to 0.4 and zoom in on the north-east corner to view the area around the Endako mine:
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Inverting Airborne Gravity Data

1. The airborne gravity for the Quest survey area together with the images of the Bouguer and terrain corrected gravity is displayed in the AirborneGrav_grid_display layout:
[image: image67.png]



This shows quite a good qualitative agreement despite the poor sample density of the ground readings.

2. The layout AirborneGrav_TC_posting can be used to read and grid the survey data supplied in the grav.xyz data file
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3. The data posting form has selected some of the fields from the file and also defined a sensor_height macro:
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4. Click on the Define Data Macros menu item and the definition of the macro is displayed:
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The definitions shows that the sensor height is calculated by evaluating the grid (which is the SRTM grid) and subtracting it from the MSLZ field in the file (which is the altitude of the aircraft above mean sea level).

5. The supplied Bouguer grid (GRVBG3KM10N.grd) is described in the ReadMe.txt file as being:



Bouguer gravity, 3km half-wavelength filter
But the grav.xyz file also has a field GRVBGL100, which is:

Simple bouguer gravity, intersection adjusted, 50s half-wavelength line filter, 2.67g/cc density

The following display shows that there seems to be more detail in the latter grid, so this was used to generate an inversion.
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6. As for the ground gravity, use the Utilities> Create a mag/grav inversion menu item on the WinDisp form and set up the main inversion parameters:
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Note: these definitions can be read from the AG_Bouguer_MGinv3D input file
7. The Observed Data for the inversion is set to be the grid AirborneGrav_BQ_GRVBGL100 and the sensor height is set to be 360m above the dtm (more on this later!)
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8. The Topo is defined using the SRTM grid:
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9. The mesh is defined using the same mesh as for the ground gravity inversion:
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10. The inversion creation process then proceeds as for the ground gravity:
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11. The inversion display once again shows that the model has fitted the data well:
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12. Loading the 0.05 g/cc isosurface into the 3D display shows that the ground and airborne inversions agree quite well in a broad qualitative sense, but there is actually a lot more detail in the model generated by the airborne data.
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13. When setting up the airborne gravity inversion, the question arises as to what height to use for the sensor. When the Bouguer grid was generated above, the MLSZ grid was also generated and looks like this:
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Clearly this looks very odd and so was judged to be not a reliable estimate of the aircraft elevation during the survey. 

14. The sensor height grid looks more reasonable and shows that the aircraft maintained an average clearance of 360m, so that value was used when setting up the inversion.
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15. The main problem with using a simple offset above the DTM when setting the sensor height is that this is not really consistent with the sensor height for the actual measurement. It would seem logical to use the actual aircraft elevation if it was available, but as the grid is generated from data which has been leveled and filtered a more realistic sensor height for the data would be some form of smooth draped surface. The exact sensor height surface which corresponds to the processed observed data cannot be determined, so we instead need to approximate it in the hope that doing so will result in a model with less dependence on the small scale dtm structures inherent in using a constant offset above the dtm to define the sensor height. One approach to doing this is to apply a smoothing filter to the DTM and then add the average sensor height to this to define the smooth draped surface. After some experimentation the DTM grid upward continued by 2000m seemed to be a good match to the broader features in the MSLZ image above:
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16. So the inversion creation setup was modified to define the sensor height by using the upward continued grid with an offset of 360m added. 

[image: image82.png]&3 3D inversion setup: AG_Bouguer_MGinv3D_sensor.inp
File _Change Working Dirctory

[E=SEcR ==~

Fasmow: | ObsevedData | Torobn

[ Cesteimain )

- DataFiles.

Observed DataFile Type [GridData  +| _Set Limits from Data

o Erorfioor [i1

- Sensor Location

Defined Value is [ Actual Sensor elevation

e

Base [4100 Scale1.0000

Sensor elevation  [RirborneGrav_BQ_TERRAIN_UCZk.grd

Graviy dota gid

|

Sensor Grid





(Note that the sensor heights in this inversion are not the same as those for the one set up above, so the mtx file needs to be generated)

17. The inversion error display is similar to the previous inversion:
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18. Adding the 0.05 g/cc isosurface to the 3D model shows that the change in sensor height has mainly affected the depth to the top of the bodies. The green isosurface is from the inversion using a constant offset above the dtm and the blue is the one using the smooth draped surface.
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Inversion of TMI data
1. The TMI data for the area of interest is contained in a number of Geosoft database files, one for each survey:

Area C
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Area D
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Area I
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Area A
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2. The data quality of areas A, D and C seem quite similar, so start a new layout and select BC I Area A - Williams Lake.grd as File 1, British Columbia - 3501 C.grd as File 2 and British Columbia - 3501 D.grd as File 3:
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3. When you display the layout, WinDisp calculates an average difference in any areas where the grid overlaps and applies a DC shift to remove this difference. The resulting merged grid has some gaps, but looks quite reasonable:
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4. Use the Export > Geosoft binary menu item to save the merged grid to the file British Columbia - 3501 ACD merge.grd
5. The grid for area I clearly has some leveling issues which need to be addressed before merging with the other TMI grids. The data for this grid were generated by digitizing a contour map, so normal leveling processes cannot be used and a strike filter will be applied to the grid file. Display the area I grid and click on the Transform Grid button on the Image Specifications form, select the Strike Filter transform and fill in the form:
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6. Click on the Perform Transform button and the convolution form of the strike filter will be applied and the output looks like this:
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7. If we start a new layout and set the merged grid from step 4 above as File 1 and the strike filtered grid from step 6 as file 2, the resulting image looks like this:
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8. Store the merged grid as British Columbia - 3501 ACDI merge.grd and then load it in a new layout and use the Fill Holes transform to fill in the gaps between the surveys.

9. Start the inversion creation utility and fill in the parameters as follows:
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10. Click on the Observed Data tab and select the merged grid file to define the data to invert:
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11. Select the SRTM grid to define the topo:
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12. Use the same mesh definitions specified for the gravity inversions:
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13. and create the inversion:
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14. The inversion error display is now a little more complex 
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The data is mostly fitted quite well, but there are clearly isolated anomalies which are causing the inversion problems, such as the circular feature in the percent error at the south-west corner. These features are predominatly associated with lows in the TMI.

15. Displaying the 50000x10^-6 SI isosurface shows some interesting features. The most prominent one is the NW trending coherence between the density and susceptibility models.
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16. There is clearly a problem with the TMI surface as it has susceptibility which dips down on each side of a central region with no susceptibility. This is a fairly strong indication that there is actually a remanently magnetized body located in the core region where the inversion has placed no susceptibility. This happens because the inversion is based on purely induced responses for magnetic material, so the inversion cannot correctly model the remanent response.
17. To investigate the probability that there is remanence involved, it is useful to transform the TMI grid using the VIAS and VRMI transforms. Before applying these filters, it is better to remove low frequency content as these cause difficulties. Appying a 5000m magnetic layer extraction yields the following grid:
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18. The VRMI transform can now be applied to this grid using the VRMI grid transform with these settings:
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19. The VIAS can also be generated using the Vertical Integral transform with the AS option turned on:
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20. and for completeness, the RTP transform is:
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21. Here is a display showing the TMI, RTP, VRMI and VIAS:
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22. There is little difference between the TMI and RTP as the magnetic field inclination is not far off vertical. But the VRMI and VIAS are quite different from the TMI and show highs over lows in the TMI image which is an indicator that there is remanence or demagnetization affecting the observed data. The VRMI and VIAS images are very similar which is a good sign that the transforms are performing well in converting the combined induced/remanent observed responses to an equivalent  vertical field induce response.

23. The inversion setup for the VRMI data is the same as for the TMI inversion with the exception that the field inclination is set to -90 and the declination to 0:
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24. The inversion error display is now much better than it was for the TMI inversion:

[image: image108.png]



25. Load the VRMI inversison and display the 50000x10^-6 SI isosurface and compare it to the same isosurface from the TMI inversion:
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It is fairly clear that the VRMI inversion has generated a much simpler model of the susceptibility which is much more geologically reasonable than the TMI version.

26. There also seems to be strong anti-correlation of susceptibility and density along the NW trending structure:
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27. One of the big problems with the VRMI transform is that it tends to amplify low frequency content in the TMI data and the resulting inversion models tend to be both broader at depoth and have much greater depth extent. The application of the MLE filter before computing the VRMI aims to counteract this behaviour by attenuating the low frequency content in the TMI image to compensate for the amplification introduced in the VRMI. This appears to have worked quite well in this instance as the bodies in the VRMI inversion seem to have quite similar dimensions and depth extents as those in the TMI inversion. The other big problem is that the VRMI data is being treated as if it was TMI data resulting from a purely induced response for a vertical field. The VRMI is defined as:

VRMI = (( TX2 + TY2 + TZ2) 
This has the same units as regular TMI data but is no longer a potential field, so using an inversion based on potential field responses introduces another layer of approximation when considering the validity of the resulting model. For this reason, the MGinv3D program has been modified to deal directly with the VRMI data by explicitly calculating the VRMI response of the susceptibility model and minimizing the data misfit (this was first implemented by Shearer, CSM). 

27. The inversion setup is similar to the VRMI inversion except that data type is set to VMI (vector magnetic intensity) and the field inclination and declination are specified as the usual inducing field directions
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28. The observed data is specified to the be VRMI transformed grid
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29. The inversion error layout shows that the data was mostly fitted quite well, though there are some problem areas in the north-eastern part of the area (which is the data digitized from TMI contours)
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30. The 50000x10^-6 SI isosurface (displayed as orange) shows a close similarity to the VRMI (in pale green) 
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But it is evident that the VMI isosurface has more structure and shows less ballooning with depth
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Adding an existing VTEM inversion
